BETA

25th May 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [25/05/24 09:21 AM] with 'Major Outage'

Issue has been resolved at [25/05/24 09:26 AM]