BETA

24th May 2024

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [24/05/24 01:11 PM] with 'Major Outage'

Issue has been resolved at [24/05/24 01:16 PM]