BETA

14th February 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [14/02/19 04:52 PM] with 'Partial Outage'

Issue has been resolved at [14/02/19 04:56 PM]