BETA

14th February 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [14/02/19 04:09 PM] with 'Major Outage'

Issue has been resolved at [14/02/19 04:10 PM]