BETA

14th February 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [14/02/19 03:55 PM] with 'Partial Outage'

Issue has been resolved at [14/02/19 03:57 PM]