Exotel Status Board
Home
Dashboard
BETA
12th May 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [12/05/24 07:10 AM] with 'Major Outage'
Issue has been resolved at [12/05/24 07:15 AM]