Exotel Status Board
Home
Dashboard
BETA
10th May 2024
Mumbai
Issue observed for 'Incoming Calls' in Mumbai Region
Identified at [10/05/24 04:10 PM] with 'Major Outage'
Issue has been resolved at [10/05/24 04:21 PM]