BETA

7th May 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [07/05/24 09:15 PM] with 'Major Outage'

Issue has been resolved at [07/05/24 09:26 PM]