BETA

7th May 2024

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [07/05/24 10:00 AM] with 'Major Outage'

Issue has been resolved at [07/05/24 10:26 AM]