BETA

11th October 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [11/10/17 03:40 PM] with 'Major Outage'

Issue has been resolved at [11/10/17 03:41 PM]