Exotel Status Board
Home
Dashboard
BETA
4th May 2024
Mumbai
Issue observed for 'Incoming Calls' in Mumbai Region
Identified at [04/05/24 11:35 PM] with 'Major Outage'
Issue has been resolved at [04/05/24 11:45 PM]