BETA

11th October 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [11/10/17 03:26 PM] with 'Partial Outage'

Issue has been resolved at [11/10/17 03:27 PM]