BETA

14th February 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [14/02/19 01:31 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/02/19 01:47 PM]