Exotel Status Board
Home
Dashboard
BETA
2nd May 2024
Mumbai
Issue observed for 'Incoming Calls' in Mumbai Region
Identified at [02/05/24 04:51 PM] with 'Major Outage'
Issue has been resolved at [02/05/24 04:55 PM]