BETA

14th February 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [14/02/19 01:03 PM] with 'Major Outage'

Issue has been resolved at [14/02/19 01:04 PM]