Exotel Status Board
Home
Dashboard
BETA
29th April 2024
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [29/04/24 08:01 PM] with 'Major Outage'
Issue has been resolved at [29/04/24 08:05 PM]