BETA

14th February 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [14/02/19 12:49 PM] with 'Partial Outage'

Issue has been resolved at [14/02/19 12:51 PM]