Exotel Status Board
Home
Dashboard
BETA
27th April 2024
Andhra Pradesh
Issue observed for 'Incoming Calls' in Andhra Pradesh Region
Identified at [27/04/24 02:10 AM] with 'Major Outage'
Issue has been resolved at [27/04/24 02:15 AM]