BETA

26th April 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [26/04/24 07:55 PM] with 'Major Outage'

Issue has been resolved at [26/04/24 08:00 PM]