Exotel Status Board
Home
Dashboard
BETA
21st April 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [21/04/24 07:55 AM] with 'Major Outage'
Issue has been resolved at [21/04/24 08:00 AM]