BETA

18th April 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [18/04/24 06:06 PM] with 'Major Outage'

Issue has been resolved at [18/04/24 06:11 PM]