BETA

18th April 2024

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [18/04/24 05:30 PM] with 'Partial Outage'

Issue has been resolved at [18/04/24 05:40 PM]