BETA

14th February 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [14/02/19 12:14 PM] with 'Partial Outage'

Issue has been resolved at [14/02/19 12:20 PM]