Exotel Status Board
Home
Dashboard
BETA
18th April 2024
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [18/04/24 01:36 AM] with 'Major Outage'
Issue has been resolved at [18/04/24 03:26 AM]