Exotel Status Board
Home
Dashboard
BETA
17th April 2024
Chennai
Issue observed for 'Outgoing Calls' in Chennai Region
Identified at [17/04/24 07:35 PM] with 'Major Outage'
Issue has been resolved at [17/04/24 07:50 PM]