BETA

17th April 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [17/04/24 03:40 PM] with 'Major Outage'

Issue has been resolved at [17/04/24 03:45 PM]