BETA

17th April 2024

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [17/04/24 12:10 PM] with 'Partial Outage'

Issue has been resolved at [17/04/24 12:20 PM]