Exotel Status Board
Home
Dashboard
BETA
16th April 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [16/04/24 07:26 PM] with 'Major Outage'
Issue has been resolved at [16/04/24 07:30 PM]