BETA

12th April 2024

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [12/04/24 11:25 AM] with 'Partial Outage'

Issue has been resolved at [12/04/24 11:46 AM]