BETA

9th April 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [09/04/24 08:25 AM] with 'Major Outage'

Issue has been resolved at [09/04/24 08:36 AM]