BETA

8th April 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [08/04/24 10:00 PM] with 'Major Outage'

Issue has been resolved at [08/04/24 10:05 PM]