BETA

14th February 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [14/02/19 10:08 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/02/19 10:15 AM]