BETA

30th March 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [30/03/24 03:55 PM] with 'Major Outage'

Issue has been resolved at [30/03/24 04:00 PM]