BETA

30th March 2024

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [30/03/24 02:49 PM] with 'Major Outage'

Issue has been resolved at [30/03/24 02:56 PM]