BETA

30th March 2024

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [30/03/24 10:15 AM] with 'Partial Outage'

Issue has been resolved at [30/03/24 10:40 AM]