BETA

30th March 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [30/03/24 07:50 AM] with 'Major Outage'

Issue has been resolved at [30/03/24 07:55 AM]