Exotel Status Board
Home
Dashboard
BETA
27th March 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [27/03/24 02:40 PM] with 'Major Outage'
Issue has been resolved at [27/03/24 02:55 PM]