BETA

27th March 2024

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [27/03/24 11:55 AM] with 'Partial Outage'

Issue has been resolved at [27/03/24 12:10 PM]