BETA

21st March 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [21/03/24 03:26 PM] with 'Major Outage'

Issue has been resolved at [21/03/24 03:40 PM]