BETA

4th September 2016

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [04/09/16 10:14 PM] with 'Partial Outage'

Issue has been resolved at [04/09/16 10:46 PM]