Exotel Status Board
Home
Dashboard
BETA
20th March 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [20/03/24 04:30 AM] with 'Major Outage'
Issue has been resolved at [20/03/24 04:36 AM]