BETA

14th February 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [14/02/19 05:57 AM] with 'Partial Outage'

Issue has been resolved at [14/02/19 05:58 AM]