BETA

14th February 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [14/02/19 05:05 AM] with 'Partial Outage'

Issue has been resolved at [14/02/19 05:08 AM]