Exotel Status Board
Home
Dashboard
BETA
13th March 2024
Andhra Pradesh
Issue observed for 'Outgoing Calls' in Andhra Pradesh Region
Identified at [13/03/24 10:55 AM] with 'Major Outage'
Issue has been resolved at [13/03/24 11:10 AM]