Exotel Status Board
Home
Dashboard
BETA
9th March 2024
Karnataka
Issue observed for 'Outgoing Calls' in Karnataka Region
Identified at [09/03/24 04:55 PM] with 'Major Outage'
Issue has been resolved at [09/03/24 05:40 PM]