Exotel Status Board
Home
Dashboard
BETA
4th March 2024
Karnataka
Issue observed for 'Outgoing Calls' in Karnataka Region
Identified at [04/03/24 12:10 PM] with 'Major Outage'
Issue has been resolved at [04/03/24 12:15 PM]