Exotel Status Board
Home
Dashboard
BETA
26th February 2024
West Bengal
Issue observed for 'Outgoing Calls' in West Bengal Region
Identified at [26/02/24 05:35 AM] with 'Major Outage'
Issue has been resolved at [26/02/24 05:41 AM]