BETA

25th February 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [25/02/24 05:15 PM] with 'Major Outage'

Issue has been resolved at [25/02/24 05:20 PM]