BETA

24th February 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [24/02/24 08:00 PM] with 'Major Outage'

Issue has been resolved at [24/02/24 08:05 PM]