Exotel Status Board
Home
Dashboard
BETA
22nd February 2024
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [22/02/24 02:15 PM] with 'Major Outage'
Issue has been resolved at [22/02/24 02:45 PM]